Spridlington, East Firsby, Owmby-by-Spital,Normanby-by-Spital,
MinorStarted Sep 11, 2026 6:48 AM · Identified
Affected:
Market Rasen and Surrounding Areas
Updates
Identified
Sep 11, 2026 12:36 PM
Our engineers have located some damage to underground cables in Spridlington. They are currently working to replace the damaged section of cables.
Identified
Sep 11, 2026 12:35 PM
We are currently aware of an issue affecting customers within this area.